The Rolex Forums   The Rolex Watch

ROLEXROLEXROLEXROLEXROLEXROLEXROLEXROLEXROLEXROLEXROLEXROLEX


Go Back   Rolex Forums - Rolex Watch Forum > Other (non-Rolex) Watch Topics > Ω Omega Discussion Forum

Reply
 
Thread Tools Display Modes
Old 25 August 2019, 05:39 AM   #1
phez
"TRF" Member
 
Join Date: Dec 2016
Real Name: Paul
Location: uk
Watch: PT DD40 Ice Blue
Posts: 369
De Ville chronograph 9300 issues ADVICE please

I purchased this Omega new in April 2019.

On running the chronograph for the first time, discovered the chronograph hour hand failed to show the correct elapsed time. After 24 hours the chronograph hour hand was 45 minutes behind. Omega have confirmed the chronograph can be used as a Second Time zone. Over 17 days it had lost 10 hours!!!

Itís been back to Omega TWICE to correct the issue but they have FAILED to fix it! It is returned with exactly the same issue and discrepancy.

The AD fails to see there is anything wrong despite Omega saying there is a fault so they wonít do anything.

Iím pressing Omega to provide a replacement as per the wording in their warranty.

Iíve sent the watch back for a THIRD time but refusing to accept it back.

Other than opening a dispute with my credit card company, am I right to press Omega for a replacement?
__________________
PT DD40 Ice Blue Quadrant Dial Blue Romans
TT SkyDweller white dial
SS Submariner Date
Omega DeVille chronograph co-axial
phez is offline   Reply With Quote
Old 25 August 2019, 08:18 AM   #2
Maxtor
2019 HARRODS BB Pledge Member
 
Join Date: Oct 2009
Real Name: Max
Location: Toronto
Watch: 2534, 2254, Exp 1
Posts: 1,955
Without doubt. Good luck and let us know how the story ends.
Maxtor is offline   Reply With Quote
Old 4 September 2019, 05:56 AM   #3
othertbone
2019 Pledge Member
 
othertbone's Avatar
 
Join Date: Nov 2018
Location: Florida, USA
Watch: Rolex/AP/Vin Omega
Posts: 978
Quote:
Originally Posted by phez View Post
I purchased this Omega new in April 2019.

On running the chronograph for the first time, discovered the chronograph hour hand failed to show the correct elapsed time. After 24 hours the chronograph hour hand was 45 minutes behind. Omega have confirmed the chronograph can be used as a Second Time zone. Over 17 days it had lost 10 hours!!!

Itís been back to Omega TWICE to correct the issue but they have FAILED to fix it! It is returned with exactly the same issue and discrepancy.

The AD fails to see there is anything wrong despite Omega saying there is a fault so they wonít do anything.

Iím pressing Omega to provide a replacement as per the wording in their warranty.

Iíve sent the watch back for a THIRD time but refusing to accept it back.

Other than opening a dispute with my credit card company, am I right to press Omega for a replacement?


That's hard to understand. Either it works or it doesn't. Is the AD providing service or it went to the Omega service center?
othertbone is online now   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


*Banner Of The Month*
This space is provided to horological resources.





Copyright ©2004-2019, The Rolex Forums. All Rights Reserved.

ROLEXROLEXROLEXROLEXROLEXROLEXROLEXROLEXROLEXROLEXROLEXROLEX

Rolex is a registered trademark of ROLEX USA. The Rolex Forums is not affiliated with ROLEX USA in any way.